CVE-2017-1000376libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack.
Updated under an hour ago ()
Does this affect you?
It affects redhat enterprise_virtualization_server and 5 other products. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.
- CVSS
- 7.0 HIGH (v3.1, NVD)CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weakness (CWE)
- CWE-119
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- Not given
- NVD analysis
- Modified
- Record last updated
- Jun 16, 2026
- First seen by InfoSec Signals
- Nov 1, 2026
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.