Back to CVE records
Medium 5.9Published Dec 7, 2017

CVE-2017-3738There is an overflow bug in the AVX2 Montgomery multiplication procedure used in exponentiation with 1024-bit moduli.

Updated under an hour ago ()

Does this affect you?

It affects openssl and 2 other products. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

There is an overflow bug in the AVX2 Montgomery multiplication procedure used in exponentiation with 1024-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH1024 are considered just feasible, because most of the work necessary to deduce information about a private key may be performed offline. The amount of resources required for such an attack would be significant. However, for an attack on TLS to be meaningful, the server would have to share the DH1024 private key among multiple clients, which is no longer an option since CVE-2016-0701. This only affects processors that support the AVX2 but not ADX extensions like Intel Haswell (4th generation). Note: The impact from this issue is similar to CVE-2017-3736, CVE-2017-3732 and CVE-2015-3193. OpenSSL version 1.0.2-1.0.2m and 1.1.0-1.1.0g are affected. Fixed in OpenSSL 1.0.2n. Due to the low severity of this issue we are not issuing a new release of OpenSSL 1.1.0 at this time. The fix will be included in OpenSSL 1.1.0h when it becomes available. The fix is also available in commit e502cc86d in the OpenSSL git repository.

Free: a daily email for up to 3 products and the weekly digest. No card, no password. By continuing you agree to the Terms and Privacy Policy.

CVSS
5.9 MEDIUM (v3.1, NVD)CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness (CWE)
CWE-200
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
Not given
NVD analysis
Modified
Record last updated
Jun 16, 2026
First seen by InfoSec Signals
Nov 1, 2026

Affected products

Affected products
openssl openssl
openssl:openssl
1.0.2; 1.0.2; 1.0.2; 1.0.2; 1.0.2a; 1.0.2b; 1.0.2c; 1.0.2d; and 17 more ranges
NVD
debian debian_linux
debian:debian_linux
8.0; 9.0
NVD
nodejs node.js
nodejs:node.js
from 4.0.0 through 4.1.2; from 4.2.0 before 4.8.7; from 6.0.0 through 6.8.1; from 6.9.0 before 6.12.2; from 8.0.0 through 8.8.1; from 8.9.0 before 8.9.3; from 9.0.0 before 9.2.1
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Essential cookies only, unless you allow a Google ads cookie. See our .