Back to CVE records
Medium 5.9Published Mar 27, 2018

CVE-2018-0733Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte.

Updated under an hour ago ()

Does this affect you?

It affects openssl. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).

Free: a daily email for up to 3 products and the weekly digest. No card, no password. By continuing you agree to the Terms and Privacy Policy.

CVSS
5.9 MEDIUM (v3.0, NVD)CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness (CWE)
Not given
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
Not given
NVD analysis
Modified
Record last updated
Jun 16, 2026
First seen by InfoSec Signals
Nov 1, 2026

Affected products

Affected products
openssl openssl
openssl:openssl
from 1.1.0 through 1.1.0g
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Essential cookies only, unless you allow a Google ads cookie. See our .