Back to CVE records
High 8.8Published Apr 13, 2022

CVE-2022-24844Gin-vue-admin is a backstage management system based on vue and gin, which separates the front and rear of the full stack.

Updated under an hour ago ()

Does this affect you?

It affects gin-vue-admin_project gin-vue-admin. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Gin-vue-admin is a backstage management system based on vue and gin, which separates the front and rear of the full stack. The problem occurs in the following code in server/service/system/sys_auto_code_pgsql.go, which means that PostgreSQL must be used as the database for this vulnerability to occur. Users must: Require JWT login) and be using PostgreSQL to be affected. This issue has been resolved in version 2.5.1. There are no known workarounds.

Free: a daily email for up to 3 products and the weekly digest. No card, no password. By continuing you agree to the Terms and Privacy Policy.

CVSS
8.8 HIGH (v3.1, NVD)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-89
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
Not given
NVD analysis
Modified
Record last updated
Jun 17, 2026
First seen by InfoSec Signals
Nov 1, 2026

Affected products

Affected products
gin-vue-admin_project gin-vue-admin
gin-vue-admin_project:gin-vue-admin
before 2.5.1
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Essential cookies only, unless you allow a Google ads cookie. See our .