Back to CVE records
High 7.5Published Nov 29, 2023

CVE-2023-49083cryptography is a package designed to expose cryptographic primitives and recipes to Python developers.

Updated under an hour ago ()

Does this affect you?

It affects cryptography.io cryptography. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Calling `load_pem_pkcs7_certificates` or `load_der_pkcs7_certificates` could lead to a NULL-pointer dereference and segfault. Exploitation of this vulnerability poses a serious risk of Denial of Service (DoS) for any application attempting to deserialize a PKCS7 blob/certificate. The consequences extend to potential disruptions in system availability and stability. This vulnerability has been patched in version 41.0.6.

Free: a daily email for up to 3 products and the weekly digest. No card, no password. By continuing you agree to the Terms and Privacy Policy.

CVSS
7.5 HIGH (v3.1, NVD)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness (CWE)
CWE-476
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
Not given
NVD analysis
Modified
Record last updated
Jun 17, 2026
First seen by InfoSec Signals
Nov 1, 2026

Affected products

Affected products
cryptography.io cryptography
cryptography.io:cryptography
from 3.1 before 41.0.6
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Essential cookies only, unless you allow a Google ads cookie. See our .