Back to CVE records
Medium 6.1Published Oct 14, 2025

CVE-2024-44088Apache Geode: Reflected XSS

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Geode and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2 Users are recommended to upgrade to version 1.15.2, which fixes the issue.

CVSS
6.1 MEDIUM (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Modified
Record last updated
Nov 4, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache Geode
apache_software_foundation:apache_geode (from the name)
from 1.1.0 before 1.15.2
CNA record
apache geode
apache:geode
from 1.1.0 before 1.15.2
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.