Back to CVE records
High 7.2Published Dec 9, 2025

CVE-2025-12705Social Reviews & Recommendations <= 2.5 - Unauthenticated Stored Cross-Site Scripting via Social Media Reviews

Updated under an hour ago ()

Does this affect you?

It affects widgetpack Reviews Widgets for Google, Yelp & TripAdvisor. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

The Social Reviews & Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.5.

CVSS
7.2 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
Wordfence
NVD analysis
Deferred
Record last updated
Apr 8, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
widgetpack Reviews Widgets for Google, Yelp & TripAdvisor
widgetpack:reviews_widgets_for_google_yelp_and_tripadvisor (from the name)
through 2.5
CNA record

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.