Back to CVE records
High 8.6Published Dec 9, 2025

CVE-2025-13428RCE in SecOps SOAR server via user-provided Python packages

Updated under an hour ago ()

Does this affect you?

It affects Google Cloud SecOps SOAR and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

A vulnerability exists in the SecOps SOAR server. The custom integrations feature allowed an authenticated user with an "IDE role" to achieve Remote Code Execution (RCE) in the server. The flaw stemmed from weak validation of uploaded Python package code. An attacker could upload a package containing a malicious setup.py file, which would execute on the server during the installation process, leading to potential server compromise. No customer action is required. All customers have been automatically upgraded to the fixed version: 6.3.64 or higher.

CVSS
8.6 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Clear
Weakness (CWE)
CWE-20
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GoogleCloud
NVD analysis
Analyzed
Record last updated
Dec 9, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Google Cloud Google Cloud SecOps SOAR
google_cloud:secops_soar (from the name)
through 6.3.64
CNA record
google security_operations_soar
google:security_operations_soar
before 6.3.64
NVD

References

  • vendor-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.