Back to CVE records
Medium 6.5Published Dec 22, 2025

CVE-2025-15033WooCommerce - Subscriber/Customer+ Order Data Disclosure

Updated under an hour ago ()

Does this affect you?

It affects Automattic WooCommerce. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.

CVSS
6.5 MEDIUM (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness (CWE)
CWE-639, CWE-200
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
WPScan
NVD analysis
Deferred
Record last updated
Mar 6, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Automattic WooCommerce
automattic:woocommerce (from the name)
from 8.1.0 before 8.1.3; from 8.2.0 before 8.2.4; from 8.3.0 before 8.3.3; from 8.4.0 before 8.4.2; from 8.5.0 before 8.5.4; from 8.6.0 before 8.6.3; from 8.7.0 before 8.7.2; from 8.8.0 before 8.8.6; and 16 more ranges
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.