Back to CVE records
High 8.6Published Mar 16, 2026

CVE-2025-15587Credentials exposure in tinycontrol devices

Updated under an hour ago ()

Does this affect you?

It affects tinycontrol Lan Kontroler v3.5 and 3 other products. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Tinycontrol devices such as tcPDU and LAN Controllers LK3.5, LK3.9 and LK4 allow a low privileged user to read an administrator's password by directly accessing a specific resource inaccessible via a graphical interface. This issue has been fixed in firmware versions: 1.36 (for tcPDU), 1.67 (for LK3.5 - hardware versions: 3.5, 3.6, 3.7 and 3.8), 1.75 (for LK3.9 - hardware version 3.9) and 1.38 (for LK4 - hardware version 4.0).

CVSS
8.6 HIGH (v4.0, CNA)CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-425
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
CERT-PL
NVD analysis
Deferred
Record last updated
Mar 16, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
tinycontrol Lan Kontroler v3.5
tinycontrol:lan_kontroler_v3.5 (from the name)
before 1.67
CNA record
tinycontrol LK3.9
tinycontrol:lk3.9 (from the name)
before 1.75
CNA record
tinycontrol LK4
tinycontrol:lk4 (from the name)
before 1.38
CNA record
tinycontrol tcPDU
tinycontrol:tcpdu (from the name)
before 1.36
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.