Back to CVE records
High 8.5Published Dec 12, 2025

CVE-2025-23408Apache Fineract: weak password policy

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Fineract and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Weak Password Requirements vulnerability in Apache Fineract. This issue affects Apache Fineract: through 1.10.1. The issue is fixed in version 1.11.0. Users are encouraged to upgrade to version 1.13.0, the latest release.

CVSS
8.5 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H
Weakness (CWE)
CWE-521
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Dec 18, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache Fineract
apache_software_foundation:apache_fineract (from the name)
through 1.10.1; 1.11.0 not affected
CNA record
apache fineract
apache:fineract
before 1.11.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.
CVE-2025-23408: Apache Fineract: weak password policy | InfoSec Signals