Back to CVE records
Critical 9.9Published Nov 6, 2025

CVE-2025-32222WordPress Widget Logic <= 6.0.5 - Remote Code Execution (RCE) Vulnerability

Updated under an hour ago ()

Does this affect you?

It affects Widgetlogic.org Widget Logic. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Improper Control of Generation of Code ('Code Injection') vulnerability in Widgetlogic.org Widget Logic widget-logic allows Code Injection.This issue affects Widget Logic: from n/a through <= 6.0.5.

CVSS
9.9 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness (CWE)
CWE-94
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
Patchstack
NVD analysis
Deferred
Record last updated
Apr 28, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Widgetlogic.org Widget Logic
widgetlogic.org:widget_logic (from the name)
through 6.0.5; fixed at 6.0.6
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.