Back to CVE records
Medium 6.3Published Oct 3, 2025

CVE-2025-46819Redis is vulnerable to DoS via specially crafted LUA scripts

Updated under an hour ago ()

Does this affect you?

It affects redis. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.

CVSS
6.3 MEDIUM (v3.1, CNA)CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:H
Weakness (CWE)
CWE-190
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Oct 31, 2025
First seen by InfoSec Signals
Oct 19, 2026

Affected products

Affected products
redis redis
redis:redis (from the name)
before 8.2.2
CNA record
redis redis
redis:redis
before 6.2.20; from 7.0 before 7.2.11; from 7.4.0 before 7.4.6; from 8.0.0 before 8.0.4; from 8.2.0 before 8.2.2
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.