Back to CVE records
Medium 6.5Published Aug 29, 2025

CVE-2025-57822Next.js Improper Middleware Redirect Handling Leads to SSRF

Updated under an hour ago ()

Does this affect you?

It affects vercel next.js. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.

CVSS
6.5 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
Weakness (CWE)
CWE-918
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Sep 2, 2025
First seen by InfoSec Signals
Oct 18, 2026

Affected products

Affected products
vercel next.js
vercel:next.js (from the name)
before 14.2.32; before 15.4.7
CNA record
vercel next.js
vercel:next.js
before 14.2.32; from 15.0.0 before 15.4.7
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.