Back to CVE records
Low 3.5Published Oct 1, 2025

CVE-2025-58054Discourse is vulnerable to XSS when quoting chat messages

Updated under an hour ago ()

Does this affect you?

It affects discourse. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.

CVSS
3.5 LOW (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
Weakness (CWE)
CWE-80
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Oct 1, 2025
First seen by InfoSec Signals
Oct 19, 2026

Affected products

Affected products
discourse discourse
discourse:discourse (from the name)
before 3.5.1
CNA record
discourse discourse
discourse:discourse
before 3.5.0; before 3.6.0; 3.6.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.
CVE-2025-58054: Discourse is vulnerable to XSS when quoting chat messages | InfoSec Signals