Back to CVE records
Medium 6.3Published Aug 29, 2025

CVE-2025-58068Eventlet affected by HTTP request smuggling in unparsed trailers

Updated under an hour ago ()

Does this affect you?

It affects eventlet. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Eventlet is a concurrent networking library for Python. Prior to version 0.40.3, the Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to, bypass front-end security controls, launch targeted attacks against active site users, and poison web caches. This problem has been patched in Eventlet 0.40.3 by dropping trailers which is a breaking change if a backend behind eventlet.wsgi proxy requires trailers. A workaround involves not using eventlet.wsgi facing untrusted clients.

CVSS
6.3 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Weakness (CWE)
CWE-444
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Modified
Record last updated
Nov 3, 2025
First seen by InfoSec Signals
Oct 19, 2026

Affected products

Affected products
eventlet eventlet
eventlet:eventlet (from the name)
before 0.40.3
CNA record
eventlet eventlet
eventlet:eventlet
before 0.40.3
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.