Back to CVE records
Critical 9.1Published Dec 12, 2025

CVE-2025-58130Apache Fineract: Server Key not masked

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Fineract and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Insufficiently Protected Credentials vulnerability in Apache Fineract. This issue affects Apache Fineract: through 1.11.0. The issue is fixed in version 1.12.1. Users are encouraged to upgrade to version 1.13.0, the latest release.

CVSS
9.1 CRITICAL (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness (CWE)
CWE-522
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Dec 12, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache Fineract
apache_software_foundation:apache_fineract (from the name)
through 1.11.0; 1.12.1 not affected
CNA record
apache fineract
apache:fineract
before 1.12.1
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.