Back to CVE records
Medium 6.3Published Jan 7, 2026

CVE-2025-58441Knowage is vulnerable to blind server-side request forgery (SSRF)

Updated under an hour ago ()

Does this affect you?

It affects KnowageLabs Knowage-Server and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, there is a blind server-side request forgery vulnerability. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker should be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.

CVSS
6.3 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-918
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Jan 7, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
KnowageLabs Knowage-Server
knowagelabs:knowage_server (from the name)
before 8.1.37
CNA record
eng knowage
eng:knowage
before 8.1.37
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.