Back to CVE records
Low 3.3Published Oct 1, 2025

CVE-2025-58769auth0-PHP: Improper File Type Handling in Bulk User Import

Updated under an hour ago ()

Does this affect you?

It affects auth0 laravel-auth0. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.

CVSS
3.3 LOW (v3.1, CNA)CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
Weakness (CWE)
CWE-22, CWE-73
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Oct 1, 2025
First seen by InfoSec Signals
Oct 19, 2026

Affected products

Affected products
auth0 laravel-auth0
auth0:laravel_auth0 (from the name)
from 3.3.0, < 8.17.0
CNA record

References

  • x-refsource-confirm
  • x-refsource-misc
  • x-refsource-misc
  • x-refsource-misc
  • x-refsource-misc
  • x-refsource-misc

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.