Back to CVE records
Medium 4.3Published Sep 5, 2025

CVE-2025-58795WordPress Payoneer Checkout Plugin <= 3.4.0 - Content Spoofing Vulnerability

Updated under an hour ago ()

This data is behind schedule: last updated Oct 26, 2026, 3:50 PM ET. We are working on it.Behind: CVE records (cvelistV5).

Does this affect you?

It affects Payoneer Checkout. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Missing Authorization vulnerability in Payoneer Checkout Payoneer Checkout payoneer-checkout allows Content Spoofing.This issue affects Payoneer Checkout: from n/a through <= 3.4.0.

CVSS
4.3 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weakness (CWE)
CWE-862
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
Patchstack
NVD analysis
Deferred
Record last updated
May 11, 2026
First seen by InfoSec Signals
Oct 18, 2026

Affected products

Affected products
Payoneer Checkout Payoneer Checkout
payoneer_checkout:payoneer_checkout (from the name)
through 3.4.0; fixed at 3.5.0
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.