Back to CVE records
Medium 5.5Published Oct 1, 2025

CVE-2025-59337Discourse: Cross-Site Data Exposure via Backup Restore Metacommand Injection in Multisite Deployments

Updated under an hour ago ()

Does this affect you?

It affects discourse. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Discourse is an open-source community discussion platform. In versions 3.5.0 and below, malicious meta-commands could be embedded in a backup dump and executed during restore. In multisite setups, this allowed an admin of one site to access data or credentials from other sites. This issue is fixed in version 3.5.1.

CVSS
5.5 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:H
Weakness (CWE)
CWE-77
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Oct 2, 2025
First seen by InfoSec Signals
Oct 19, 2026

Affected products

Affected products
discourse discourse
discourse:discourse (from the name)
before 3.5.1
CNA record
discourse discourse
discourse:discourse
before 3.5.1; before 3.6.0; 3.6.0
NVD

References

  • x-refsource-confirm, vendor-advisory
  • x-refsource-misc, patch

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.