Back to CVE records
Critical 9.1Published Sep 23, 2025

CVE-2025-59545DNN Vulnerable to Stored Cross-Site Scripting (XSS) in the Prompt module

Updated under an hour ago ()

Does this affect you?

It affects dnnsoftware Dnn.Platform and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 10.1.0, the Prompt module allows execution of commands that can return raw HTML. Malicious input, even if sanitized for display elsewhere, can be executed when processed through certain commands, leading to potential script execution (XSS). This issue has been patched in version 10.1.0.

CVSS
9.1 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Sep 23, 2025
First seen by InfoSec Signals
Oct 11, 2026

Affected products

Affected products
dnnsoftware Dnn.Platform
dnnsoftware:dnn.platform (from the name)
before 10.1.0
CNA record
dnnsoftware dotnetnuke
dnnsoftware:dotnetnuke
before 10.1.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.