Back to CVE records
Medium 6.5Published Sep 29, 2025

CVE-2025-59940mkdocs-include-markdown-plugin susceptible to unvalidated input colliding with substitution placeholders

Updated under an hour ago ()

Does this affect you?

It affects mondeja mkdocs-include-markdown-plugin. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.

CVSS
6.5 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness (CWE)
CWE-20
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Sep 30, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
mondeja mkdocs-include-markdown-plugin
mondeja:mkdocs_include_markdown_plugin (from the name)
before 7.1.8
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.