Back to CVE records
High 8.6Published Oct 3, 2025

CVE-2025-61673Karapace is vulnerable to Authentication Bypass

Updated under an hour ago ()

Does this affect you?

It affects Aiven-Open karapace. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Karapace is an open-source implementation of Kafka REST and Schema Registry. Versions 5.0.0 and 5.0.1 contain an authentication bypass vulnerability when configured to use OAuth 2.0 Bearer Token authentication. If a request is sent without an Authorization header, the token validation logic is skipped entirely, allowing an unauthenticated user to read and write to Schema Registry endpoints that should otherwise be protected. This effectively renders the OAuth authentication mechanism ineffective. This issue is fixed in version 5.0.2.

CVSS
8.6 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L
Weakness (CWE)
CWE-306, CWE-288
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Oct 6, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Aiven-Open karapace
aiven_open:karapace (from the name)
from 5.0.0, < 5.0.2
CNA record

References

  • x-refsource-confirm
  • x-refsource-misc
  • x-refsource-misc

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.