Back to CVE records
High 7.5Published Oct 2, 2025

CVE-2025-61734Apache Kylin: improper restriction of file read

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Kylin and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. Users are recommended to upgrade to version 5.0.3, which fixes the issue.

CVSS
7.5 HIGH (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness (CWE)
CWE-552
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Modified
Record last updated
Nov 4, 2025
First seen by InfoSec Signals
Oct 12, 2026

Affected products

Affected products
Apache Software Foundation Apache Kylin
apache_software_foundation:apache_kylin (from the name)
from 4.0.0 through 5.0.2
CNA record
apache kylin
apache:kylin
from 4.0.0 before 5.0.3
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.