Back to CVE records
Medium 5.5Published Oct 13, 2025

CVE-2025-62365LibreNMS vulnerable to Reflected-XSS in `report_this` function

Updated under an hour ago ()

Does this affect you?

It affects librenms. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Prior to 25.7.0, there is a reflected-XSS in `report_this` function in `librenms/includes/functions.php`. The `report_this` function had improper filtering (`htmlentities` function was incorrectly use in a href environment), which caused the `project_issues` parameter to trigger an XSS vulnerability. This vulnerability is fixed in 25.7.0.

CVSS
5.5 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Oct 14, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
librenms librenms
librenms:librenms (from the name)
before 25.7.0
CNA record
librenms librenms
librenms:librenms
before 25.7.0
NVD

References

  • x-refsource-confirm, exploit, vendor-advisory
  • x-refsource-misc, patch

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.