Back to CVE records
High 8.3Published Nov 20, 2025

CVE-2025-62372vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs

Updated under an hour ago ()

Does this affect you?

It affects vllm-project vllm and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

CVSS
8.3 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H
Weakness (CWE)
CWE-129
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Nov 24, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
vllm-project vllm
vllm_project:vllm (from the name)
from 0.5.5, < 0.11.1
CNA record
vllm vllm
vllm:vllm
from 0.5.5 before 0.11.1; 0.11.1; 0.11.1
NVD

References

  • x-refsource-confirm, mitigation, vendor-advisory
  • x-refsource-misc, issue-tracking, patch, vendor-advisory
  • x-refsource-misc, issue-tracking
  • x-refsource-misc, patch

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.