Back to CVE records
Medium 5.4Published Oct 28, 2025

CVE-2025-62801FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name

Updated under an hour ago ()

Does this affect you?

It affects jlowin fastmcp. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vulnerability is fixed in 2.13.0.

CVSS
5.4 MEDIUM (v4.0, CNA)CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-78
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Oct 29, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
jlowin fastmcp
jlowin:fastmcp (from the name)
before 2.13.0
CNA record
jlowin fastmcp
jlowin:fastmcp
before 2.13.0
NVD

References

  • x-refsource-confirm, exploit, third-party-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.