Back to CVE records
High 8.7Published Nov 4, 2025

CVE-2025-64110Cursor: Authentication Bypass Possible via New Cursorignore Write

Updated under an hour ago ()

Does this affect you?

It affects cursor and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Cursor is a code editor built for programming with AI. In versions 1.7.23 and below, a logic bug allows a malicious agent to read sensitive files that should be protected via cursorignore. An attacker who has already achieved prompt injection, or a malicious model, could create a new cursorignore file which can invalidate the configuration of pre-existing ones. This could allow a malicious agent to read protected files. This issue is fixed in version 2.0.

CVSS
8.7 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-284
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Nov 7, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
cursor cursor
cursor:cursor (from the name)
before 2.0
CNA record
anysphere cursor
anysphere:cursor
before 2.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.