Back to CVE records
High 8.9Published Nov 5, 2025

CVE-2025-64164DataEase is vulnerable to Oracle JNDI Injection

Updated under an hour ago ()

Does this affect you?

It affects dataease. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Dataease is an open source data visualization analysis tool. In versions 2.10.14 and below, DataEase did not properly filter when establishing JDBC connections to Oracle, resulting in a risk of JNDI injection (Java Naming and Directory Interface injection). This issue is fixed in version 2.10.15.

CVSS
8.9 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
Weakness (CWE)
CWE-502
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Nov 6, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
dataease dataease
dataease:dataease (from the name)
before 2.10.15
CNA record
dataease dataease
dataease:dataease
before 2.10.15
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.