Back to CVE records
High 8.4Published Nov 18, 2025

CVE-2025-64325Emby Server is Vulnerable to Remote Code Execution Through XSS in Admin Dashboard

Updated under an hour ago ()

Does this affect you?

It affects EmbySupport Emby.Security and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Emby Server is a personal media server. Prior to version 4.8.1.0 and prior to Beta version 4.9.0.0-beta, a malicious user can send an authentication request with a manipulated X-Emby-Client value, which gets added to the devices section of the admin dashboard without sanitization. This issue has been patched in version 4.8.1.0 and Beta version 4.9.0.0-beta.

CVSS
8.4 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-79, CWE-116
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Nov 19, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
EmbySupport Emby.Security
embysupport:emby.security (from the name)
Emby Server (Web App) < 4.8.1.0; Emby Server Beta (Web App) < 4.9.0.0-beta
CNA record
emby emby
emby:emby
before 4.8.1.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.