Back to CVE records
Low 2.7Published Oct 31, 2025

CVE-2025-64352WordPress Essential Addons for Elementor plugin <= 6.2.4 - Broken Access Control vulnerability

Updated under an hour ago ()

Does this affect you?

It affects WPDeveloper Essential Addons for Elementor. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Missing Authorization vulnerability in WPDeveloper Essential Addons for Elementor essential-addons-for-elementor-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Essential Addons for Elementor: from n/a through <= 6.2.4.

CVSS
2.7 LOW (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
Weakness (CWE)
CWE-862
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
Patchstack
NVD analysis
Modified
Record last updated
Apr 28, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
WPDeveloper Essential Addons for Elementor
wpdeveloper:essential_addons_for_elementor (from the name)
through 6.2.4; fixed at 6.3.0
CNA record
wpdeveloper essential_addons_for_elementor
wpdeveloper:essential_addons_for_elementor
before 6.3.0
NVD

References

  • vdb-entry, third-party-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.