Back to CVE records
Medium 6.3Published Nov 19, 2025

CVE-2025-64408Apache Causeway: Java deserialization vulnerability to authenticated attackers

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Causeway and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.  This issue affects all current versions. Users are recommended to upgrade to version 3.5.0, which fixes the issue.

CVSS
6.3 MEDIUM (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness (CWE)
CWE-502
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Feb 26, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache Causeway
apache_software_foundation:apache_causeway (from the name)
from 2.0.0 through 3.4.0; 4.0.0-M1
CNA record
apache causeway
apache:causeway
from 2.0.0 before 3.5.0; 4.0.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.