Back to CVE records
High 8.9Published Nov 20, 2025

CVE-2025-64428DataEase DB2 JNDI Vulnerability

Updated under an hour ago ()

Does this affect you?

It affects dataease. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Dataease is an open source data visualization analysis tool. Versions prior to 2.10.17 are vulnerable to JNDI injection. A blacklist was added in the patch for version 2.10.14. However, JNDI injection remains possible via the iiop, corbaname, and iiopname schemes. The vulnerability has been fixed in version 2.10.17.

CVSS
8.9 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
Weakness (CWE)
CWE-74
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Nov 21, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
dataease dataease
dataease:dataease (from the name)
before 2.10.17
CNA record
dataease dataease
dataease:dataease
before 2.10.17
NVD

References

  • x-refsource-confirm, exploit, vendor-advisory
  • x-refsource-misc, patch
  • x-refsource-misc, release-notes

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.