Back to CVE records
Medium 5.8Published Nov 20, 2025

CVE-2025-64751OpenFGA Improper Policy Enforcement

Updated under an hour ago ()

Does this affect you?

It affects openfga and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.

CVSS
5.8 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
Weakness (CWE)
CWE-285
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Nov 24, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
openfga openfga
openfga:openfga (from the name)
from 1.4.0, < 1.11.1
CNA record
openfga helm_charts
openfga:helm_charts
from 0.1.34 before 0.2.49
NVD
openfga openfga
openfga:openfga
from 1.4.0 before 1.11.1
NVD

References

  • x-refsource-confirm, vendor-advisory
  • x-refsource-misc, release-notes

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.