Back to CVE records
Critical 9.1Published Nov 21, 2025

CVE-2025-64767hpke-js reuses AEAD nonces

Updated under an hour ago ()

Does this affect you?

It affects dajiaji hpke-js. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

hpke-js is a Hybrid Public Key Encryption (HPKE) module built on top of Web Cryptography API. Prior to version 1.7.5, the public SenderContext Seal() API has a race condition which allows for the same AEAD nonce to be re-used for multiple Seal() calls. This can lead to complete loss of Confidentiality and Integrity of the produced messages. This issue has been patched in version 1.7.5.

CVSS
9.1 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness (CWE)
CWE-323
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Nov 21, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
dajiaji hpke-js
dajiaji:hpke_js (from the name)
before 1.7.5
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.