Back to CVE records
Critical 9.4Published Nov 19, 2025

CVE-2025-65095Lookyloo is vulnerable due to improper user input sanitization

Updated under an hour ago ()

Does this affect you?

It affects lookyloo. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to version 1.35.1, there is potential cross-site scripting on index and tree page. This issue has been patched in version 1.35.1.

CVSS
9.4 CRITICAL (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Nov 20, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Lookyloo lookyloo
lookyloo:lookyloo (from the name)
before 1.35.1
CNA record

References

  • x-refsource-confirm
  • x-refsource-misc
  • x-refsource-misc
  • x-refsource-misc

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.