Back to CVE records
Medium 6.5Published Nov 21, 2025

CVE-2025-65107Langfuse SSO Account Takeover via CSRF or phishing attack

Updated under an hour ago ()

Does this affect you?

It affects langfuse. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_<PROVIDER>_CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2.95.12 and 3.131.0. A workaround for this issue involves setting AUTH_<PROVIDER>_CHECK.

CVSS
6.5 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Weakness (CWE)
CWE-352, CWE-285
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Nov 24, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
langfuse langfuse
langfuse:langfuse (from the name)
from 2.95.0, < 2.95.12; from 3.17.0, < 3.131.0
CNA record
langfuse langfuse
langfuse:langfuse
from 2.95.0 before 2.95.12; from 3.17.0 before 3.131.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.