Back to CVE records
High 7.8Published Dec 10, 2025

CVE-2025-65199Windscribe for Linux 'changeMTU' local privilege escalation

Updated under an hour ago ()

Does this affect you?

It affects Windscribe for Linux Desktop App and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.

CVSS
7.8 HIGH (v3.1, CNA)CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-78
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
cisa-cg
NVD analysis
Analyzed
Record last updated
Dec 18, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Windscribe Windscribe for Linux Desktop App
windscribe:for_linux_desktop_app (from the name)
from 2.10.1 before 2.18.3-alpha; from 2.10.1 before 2.18.8; 2.18.3-alpha not affected; 2.18.8 not affected
CNA record
windscribe windscribe
windscribe:windscribe
from 2.10.1 through 2.17.10; 2.18.1; 2.18.3; 2.18.5
NVD

References

  • product
  • patch
  • patch
  • technical-description, third-party-advisory, exploit, press/media-coverage
  • third-party-advisory, us-government-resource
  • government-resource, third-party-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.