Back to CVE records
Medium 5.1Published Nov 24, 2025

CVE-2025-65944Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`

Updated under an hour ago ()

Does this affect you?

It affects getsentry sentry-javascript. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.

CVSS
5.1 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:L
Weakness (CWE)
CWE-201
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Nov 25, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
getsentry sentry-javascript
getsentry:sentry_javascript (from the name)
from 10.11.0, < 10.27.0
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.