Back to CVE records
High 8.1Published Nov 21, 2025

CVE-2025-65946Roo Code is Vulnerable to Potential Remote Code Execution via zsh Command Validation Bug

Updated under an hour ago ()

Does this affect you?

It affects RooCodeInc Roo-Code and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Roo Code is an AI-powered autonomous coding agent that lives in users' editors. Prior to version 3.26.7, Due to an error in validation it was possible for Roo to automatically execute commands that did not match the allow list prefixes. This issue has been patched in version 3.26.7.

CVSS
8.1 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-77, CWE-20
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Nov 25, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
RooCodeInc Roo-Code
roocodeinc:roo_code (from the name)
before 3.26.7
CNA record
roocode roo_code
roocode:roo_code
before 3.26.7
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.