CVE-2025-66032Claude Code Command Validation Bypass Allows Arbitrary Code Execution
Updated under an hour ago ()
Does this affect you?
It affects anthropics claude-code and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Claude Code is an agentic coding tool. Prior to 1.0.93, Due to errors in parsing shell commands related to $IFS and short CLI flags, it was possible to bypass the Claude Code read-only validation and trigger arbitrary code execution. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. This vulnerability is fixed in 1.0.93.
- CVSS
- 8.7 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Weakness (CWE)
- CWE-77
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- Dec 3, 2025
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
anthropics claude-code anthropics:claude_code (from the name) | before 1.0.93 | CNA record |
anthropic claude_code anthropic:claude_code | before 1.0.93 | NVD |
References
- https://github.com/anthropics/claude-code/security/advisories/GHSA-xq4m-mc3c-vvg3x-refsource-confirm, vendor-advisory
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.