Back to CVE records
Medium 6.3Published Nov 28, 2025

CVE-2025-66034fontTools is Vulnerable to Arbitrary File Write and XML injection in fontTools.varLib

Updated under an hour ago ()

Does this affect you?

It affects fonttools. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

fontTools is a library for manipulating fonts, written in Python. In versions from 4.33.0 to before 4.60.2, the fonttools varLib (or python3 -m fontTools.varLib) script has an arbitrary file write vulnerability that leads to remote code execution when a malicious .designspace file is processed. The vulnerability affects the main() code path of fontTools.varLib, used by the fonttools varLib CLI and any code that invokes fontTools.varLib.main(). This issue has been patched in version 4.60.2.

CVSS
6.3 MEDIUM (v3.1, CNA)CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:L
Weakness (CWE)
CWE-91
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 1, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
fonttools fonttools
fonttools:fonttools (from the name)
from 4.33.0, < 4.60.2
CNA record
fonttools fonttools
fonttools:fonttools
from 4.33.0 before 4.60.2
NVD

References

  • x-refsource-confirm, exploit, vendor-advisory
  • x-refsource-misc, patch

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.