CVE-2025-66040Spotipy has a XSS vulnerability in OAuth callback server
Updated under an hour ago ()
Does this affect you?
It affects spotipy-dev spotipy. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.
- CVSS
- 3.6 LOW (v3.1, CNA)CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
- Weakness (CWE)
- CWE-79
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Deferred
- Record last updated
- Nov 28, 2025
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
spotipy-dev spotipy spotipy_dev:spotipy (from the name) | before 2.25.2 | CNA record |
References
- https://github.com/spotipy-dev/spotipy/security/advisories/GHSA-r77h-rpp9-w2xmx-refsource-confirm
- https://github.com/spotipy-dev/spotipy/commit/880b92d7243dcf2b83bf31dc365a858d8b5e6767x-refsource-misc
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.