Back to CVE records
High 8.6Published Nov 28, 2025

CVE-2025-66201LibreChat is Vulnerable to Server-Side Request Forgery (SSRF) in Actions Capability

Updated under an hour ago ()

Does this affect you?

It affects danny-avila LibreChat and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

LibreChat is a ChatGPT clone with additional features. Prior to version 0.8.1-rc2, LibreChat is vulnerable to Server-side Request Forgery (SSRF), by passing specially crafted OpenAPI specs to its "Actions" feature and making the LLM use those actions. It could be used by an authenticated user with access to this feature to access URLs only accessible to the LibreChat server (such as cloud metadata services, through which impersonation of the server might be possible). This issue has been patched in version 0.8.1-rc2.

CVSS
8.6 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-20, CWE-918
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 1, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
danny-avila LibreChat
danny_avila:librechat (from the name)
before 0.8.1-rc2
CNA record
librechat librechat
librechat:librechat
before 0.8.1; 0.8.1; 0.8.1
NVD

References

  • x-refsource-confirm, exploit, vendor-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.