Back to CVE records
High 7.0Published Dec 9, 2025

CVE-2025-66214Ladybug has an XMLDecoder Deserialization Vulnerability (Java RCE)

Updated under an hour ago ()

Does this affect you?

It affects wearefrank ladybug. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Ladybug adds message-based debugging, unit, system, and regression testing to Java applications. Versions prior to 3.0-20251107.114628 contain the APIs /iaf/ladybug/api/report/{storage} and /iaf/ladybug/api/report/upload, which allow uploading gzip-compressed XML files with user-controllable content. The system deserializes these XML files, enabling attackers to achieve Remote Code Execution (RCE) by submitting carefully crafted XML payloads and thereby gain access to the target server. This issue is fixed in version 3.0-20251107.114628.

CVSS
7.0 HIGH (v3.1, CNA)CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L
Weakness (CWE)
CWE-502
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 9, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
wearefrank ladybug
wearefrank:ladybug (from the name)
before 3.0-20251107.114628
CNA record
wearefrank ladybug
wearefrank:ladybug
before 3.0-20251107.114628
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.