Back to CVE records
Critical 9.3Published Nov 28, 2025

CVE-2025-66216AIS-catcher has a Buffer Overflow vulnerability in `AIS::Message` leading to DoS/RCE

Updated under an hour ago ()

Does this affect you?

It affects jvde-github AIS-catcher and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

AIS-catcher is a multi-platform AIS receiver. Prior to version 0.64, a heap buffer overflow vulnerability has been identified in the AIS::Message class of AIS-catcher. This vulnerability allows an attacker to write approximately 1KB of arbitrary data into a 128-byte buffer. This issue has been patched in version 0.64.

CVSS
9.3 CRITICAL (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-131
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 1, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
jvde-github AIS-catcher
jvde_github:ais_catcher (from the name)
before 0.64
CNA record
aiscatcher ais-catcher
aiscatcher:ais-catcher
before 0.64
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.