Back to CVE records
Medium 5.3Published Dec 11, 2025

CVE-2025-66451LibreChat's Improper Input Validation in Prompt Creation API Enables Unauthorized Permission Changes

Updated under an hour ago ()

Does this affect you?

It affects danny-avila LibreChat and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently validated for proper input, enabling users to modify prompts in a way that was not intended as part of the front end system. The patchPromptGroup function passes req.body directly to updatePromptGroup() without filtering sensitive fields. This issue is fixed in version 0.8.1.

CVSS
5.3 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-20, CWE-915
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 12, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
danny-avila LibreChat
danny_avila:librechat (from the name)
before 0.8.1
CNA record
librechat librechat
librechat:librechat
before 0.8.1
NVD

References

  • x-refsource-confirm, exploit, vendor-advisory
  • x-refsource-misc, patch

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.