Back to CVE records
High 8.9Published Dec 5, 2025

CVE-2025-66562TUUI vulnerable to Remote Code Execution (RCE) via XSS in Markdown ECharts Rendering

Updated under an hour ago ()

Does this affect you?

It affects AI-QL tuui and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

TUUI is a desktop MCP client designed as a tool unitary utility integration. Prior to 1.3.4, a critical Remote Code Execution (RCE) vulnerability exists in Tuui due to an unsafe Cross-Site Scripting (XSS) flaw in the Markdown rendering component. Tuui allows the execution of arbitrary JavaScript within ECharts code blocks. Combined with an exposed IPC interface that allows spawning processes, an attacker can execute arbitrary system commands on the victim's machine simply by having them view a malicious Markdown message. This vulnerability is fixed in 1.3.4.

CVSS
8.9 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Weakness (CWE)
CWE-79, CWE-94
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 5, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
AI-QL tuui
ai_ql:tuui (from the name)
before 1.3.4
CNA record
aiql tuui
aiql:tuui
before 1.3.4
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.