Back to CVE records
High 8.2Published Dec 5, 2025

CVE-2025-66566yawkat LZ4 Java has a possible information leak in Java safe decompressor

Updated under an hour ago ()

Does this affect you?

It affects yawkat lz4-java. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

yawkat LZ4 Java provides LZ4 compression for Java. Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. JNI-based implementations are not affected. This vulnerability is fixed in 1.10.1.

CVSS
8.2 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-201
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Dec 5, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
yawkat lz4-java
yawkat:lz4_java (from the name)
before 1.10.1
CNA record

References

  • x-refsource-confirm
  • x-refsource-misc

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.